読者です 読者をやめる 読者になる 読者になる

Ubuntuでhulu.jpを視聴できなくなったので何とかしてみた



※2016年12月17日、Firefox用のFlashプラグインがバージョン24のアップデートされたため、huluを視聴できなくなったようです。

何か再生されなくなったらしい。hulu側の仕様が変更された?

Google Chromeでhuluの動画を再生しようとすると、

保護されたコンテンツを再生中に問題が発生しています。動画を再生し直すか、弊社カスタマーサポートまでお問い合わせください。(3336)

というエラーメッセージが表示される。知恵袋の回答によるとhalをインストールすればいいらしいが、現在halのパッケージはUbuntu 12.04にしか存在しない。ググると15.10用のhalがppaにあったので、それをインストールしたら一応Firefoxでhuluが見られるようになった(Google Chromeは見れないまま)。
以下実行したコマンド。

rm -rf ~/.adobe/ 
sudo add-apt-repository ppa:mjblenner/ppa-hal 
sudo apt-get update 
sudo apt-get install hal hal-info 

huluのトラブルシューティングに「保護されたコンテンツに関するエラー」のページがあったのだが、

そのページに書いてある 保護されたコンテンツのIDを許可する という項目はLinuxGoogle Chromeには存在しない。LinuxFirefox用のFlashプラグインはサポート期間が2017年2月ごろまでらしいので、それまでにChromeが対応してくれないとUbuntuではhuluが見られなくなる。