読者です 読者をやめる 読者になる 読者になる

Ubuntu 14.04.3でlanguage-pack-jaをアップデートできないバグに対応する

Ubuntu バグ・不具合

現在Ubuntu 14.04には依存関係が壊れていてlanguage-pack-jaをアップデートできないバグがある。そのうち修正されるだろうと思っていたら、意外と時間がかかっているようなので自力で何とかしてみた。
端末で、

sudo apt-get purge language-pack-ja
wget http://ftp.jaist.ac.jp/pub/Linux/ubuntu/pool/main/l/language-pack-ja/language-pack-ja_14.04+20150804_all.deb
wget http://ftp.jaist.ac.jp/pub/Linux/ubuntu/pool/main/l/language-pack-ja-base/language-pack-ja-base_14.04+20150804_all.deb
wget http://ftp.jaist.ac.jp/pub/Linux/ubuntu/pool/main/l/language-pack-gnome-ja/language-pack-gnome-ja_14.04+20150804_all.deb
wget http://ftp.jaist.ac.jp/pub/Linux/ubuntu/pool/main/l/language-pack-gnome-ja-base/language-pack-gnome-ja-base_14.04+20150804_all.deb
sudo dpkg -i language-pack-*.deb
sudo apt-get install ubuntu-defaults-ja
rm language-pack-*.deb

と実行したらアップデートできたっぽい。